Back to overview
Resolved

Primary database experiencing degraded performance

Jul 19, 2026 at 5:22pm UTC
Affected services
Database (Primary)

Resolved
Jul 19, 2026 at 5:28pm UTC

Resolved — our team identified and fixed the primary database slowdown within 7 minutes. All services are back to normal, and no further action is needed.

Created
Jul 19, 2026 at 5:22pm UTC

Our main database is currently downgraded and running slower than usual. We're investigating the cause. In the meantime, we've switched to our secondary databases to handle requests so users aren't affected. We'll share updates as soon as we know more.